wireshark-dev October 2010 archive
Main Archive Page > Month Archives  > wireshark-dev archives
wireshark-dev: Re: [Wireshark-dev] Updating plugin for 1.4.0

Re: [Wireshark-dev] Updating plugin for 1.4.0

From: Jaap Keuter <jaap.keuter_at_nospam>
Date: Tue Oct 05 2010 - 15:06:00 GMT
To: Developer support list for Wireshark <wireshark-dev@wireshark.org>

Hi Beth,

Things have been tightened up to prevent crashes from
happening. Seems that your dissector does something it shouldn't.

Get
out your debugger and see what it tells you.

Thanks,
Jaap

On Tue, 5
Oct 2010 10:49:03 -0400, Beth wrote:

I wrote some plugins under
1.2.x awhile back, which have been used successfully for some time now.

I tried using them with 1.4.0 (hey it was worth a shot :) but got an
error so I downloaded the 1.4.0 tarball and rebuilt them. However I
still get the error! Can those of you with 1.4 knowledge suggest where I
should start looking for the problem? The error is simply:

10:39:15
Warn Dissector bug, protocol MyProto, in packet 1:
STATUS_ACCESS_VIOLATION: dissector accessed an invalid memory address

Whatever it is, it's something that happens with 1.4.0 but not with
1.2.11 . I have not (yet) touched the plugin source code.
Any
suggestions appreciated!

b.

 

___________________________________________________________________________
Sent via: Wireshark-dev mailing list <wireshark-dev@wireshark.org>
Archives: http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:wireshark-dev-request@wireshark.org?subject=unsubscribe