spamassassin-users March 2010 archive
Main Archive Page > Month Archives  > spamassassin-users archives
spamassassin-users: RE: Upgrading to SpamAssassin 3.3

RE: Upgrading to SpamAssassin 3.3

From: Randal, Phil <prandal_at_nospam>
Date: Wed Mar 17 2010 - 16:36:05 GMT
To: "Kaleb Hosie" <khosie@spectraaluminum.com>, <users@spamassassin.apache.org>

How did you install it? From CPAN or via (for example) rpmforge?

What does

   rpm -qa | grep NetAddr

tell you?

BTW, one other thing necessary with a 3.3.x install is an immediate
sa-update to get the rules, which are no longer included in the SA
tarball.

Cheers,

Phil
-- Phil Randal | Networks Engineer NHS Herefordshire & Herefordshire Council | Deputy Chief Executive's Office | I.C.T. Services Division Thorn Office Centre, Rotherwas, Hereford, HR2 6JT Tel: 01432 260160 email: prandal@herefordshire.gov.uk Any opinion expressed in this e-mail or any attached files are those of the individual and not necessarily those of Herefordshire Council. This e-mail and any attached files are confidential and intended solely for the use of the addressee. This communication may contain material protected by law from being passed on. If you are not the intended recipient and have received this e-mail in error, you are advised that any use, dissemination, forwarding, printing or copying of this e-mail is strictly prohibited. If you have received this e-mail in error please contact the sender immediately and destroy all copies of it. -----Original Message----- From: Kaleb Hosie [mailto:khosie@spectraaluminum.com] Sent: 17 March 2010 16:26 To: users@spamassassin.apache.org Subject: RE: Upgrading to SpamAssassin 3.3 I do have a test VM so I thought I would go ahead and try out 3.3.0 for now. I ran into a bit of an issue with the NetAddr::IP module. I've installed it but when I try to install the built RPM file it gives me this error: error: Failed dependencies: perl(NetAddr::IP) >= 4.000 is needed by perl-Mail-SpamAssassin-3.3.0-1.i386 [root@Mailgate i386]# perl -le 'use NetAddr::IP; print NetAddr::IP->VERSION' 4.027 I've searched google and it seems that I'm not the first to have this problem but I can't seem to find a solution. Have any of you run into this problem? Thanks -----Original Message----- From: Randal, Phil [mailto:prandal@herefordshire.gov.uk] Sent: Wednesday, March 17, 2010 11:46 AM To: Kaleb Hosie; users@spamassassin.apache.org Subject: RE: Upgrading to SpamAssassin 3.3 3.3.0 works fine on CentOS 5.4, but 3.3.1 is due out imminently (in the next week or two), so I'd hold back for that. Read the release notes carefully and ensure that 3.3.x's prerequisites are installed. If you have a test VM you can install on, use it. I tested on a CentOS 5.4 VM on my home PC :-) Updating was plain sailing for me. Cheers, Phil -- Phil Randal | Networks Engineer NHS Herefordshire & Herefordshire Council | Deputy Chief Executive's Office | I.C.T. Services Division Thorn Office Centre, Rotherwas, Hereford, HR2 6JT Tel: 01432 260160 email: prandal@herefordshire.gov.uk Any opinion expressed in this e-mail or any attached files are those of the individual and not necessarily those of Herefordshire Council. This e-mail and any attached files are confidential and intended solely for the use of the addressee. This communication may contain material protected by law from being passed on. If you are not the intended recipient and have received this e-mail in error, you are advised that any use, dissemination, forwarding, printing or copying of this e-mail is strictly prohibited. If you have received this e-mail in error please contact the sender immediately and destroy all copies of it. -----Original Message----- From: Kaleb Hosie [mailto:khosie@spectraaluminum.com] Sent: 17 March 2010 15:36 To: users@spamassassin.apache.org Subject: Upgrading to SpamAssassin 3.3 Hello, I'm running SA 3.2.5 on CentOS 5.4 and I've noticed that a newer major release has been released. The server is currently in production so I'm a bit leery to upgrade. Do you feel that it is worth the upgrade to 3.3? Is there anything I should know before I go ahead and upgrade? Thanks for your help Any opinion expressed in this e-mail or any attached files are those of the individual and not necessarily those of Herefordshire Council. You should be aware that Herefordshire Council monitors its email service. This e-mail and any attached files are confidential and intended solely for the use of the addressee. This communication may contain material protected by law from being passed on. If you are not the intended recipient and have received this e-mail in error, you are advised that any use, dissemination, forwarding, printing or copying of this e-mail is strictly prohibited. If you have received this e-mail in error please contact the sender immediately and destroy all copies of it.