spamassassin-dev November 2011 archive
Main Archive Page > Month Archives  > spamassassin-dev archives
spamassassin-dev: [Bug 6599] Add Geo::IP support

[Bug 6599] Add Geo::IP support

From: <bugzilla-daemon_at_nospam>
Date: Mon Nov 28 2011 - 15:33:35 GMT
To: dev@spamassassin.apache.org

https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6599

--- Comment #13 from Matt Dainty <matt@bodgit-n-scarper.com> 2011-11-28 15:33:35 UTC ---
I completely agree on having two plugins, I just wrote a new one to keep it
separate as personally I'll never run it on a host that doesn't have Geo::IP
available. I also didn't want to mess with the SA package $OS provided.

Personally, IP::Country is no good to me going forward as it simply doesn't
have IPv6 data so I'd rather just move to Geo::IP entirely, but I wouldn't mind
if IP::Country was the fallback option. The data files then also get shared by
other things using the GeoIP C library.

If it's useful and could potentially be accepted, I'm happy to whip up a patch
to the current plugin that supports both backends, assuming any licensing issue
is resolved.

Oh, I forgot to mention, I think you'll need at least Geo::IP 1.39 to get the
IPv6 API methods, although I've been using 1.40, and that needs something like
1.4.7 of the C library.

-- Configure bugmail: https://issues.apache.org/SpamAssassin/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are the assignee for the bug.