snort-devel April 2008 archive
Main Archive Page > Month Archives  > snort-devel archives
snort-devel: Re: [Snort-devel] Errors compiling Snort 2.8.1 with

Re: [Snort-devel] Errors compiling Snort 2.8.1 with IPv6 and Prelude support

From: Steven Sturges <steve.sturges_at_nospam>
Date: Wed Apr 16 2008 - 21:39:29 GMT
To: Christopher Blume <cblume.lists@gmail.com>


Hi Christopher--

For the 1st issue, the simple answer is to add a #include "ipv6_port.h" to spo_alert_prelude.c, around line 50.

However, that should be done with caution, as the result could change the length of data following "icmp_gwaddr". You'd have to update the back-end to process an IPv6 address as well.

For the 2nd, change the function signature for snort_alert_prelude_init to use char *, instead of unsigned char *.

That should at least get you headed in the right direction. :)

Cheers.
-steve

Christopher Blume wrote:
> Hello all,
>
> I first posted this to snort-users, it appears I should've posted it
> to the devel list instead, so here it is.
>
> We had someone drop by the #snort channel last night; skor. He
> reported a problem compiling Snort 2.8.1 with both IPv6 and Prelude
> support enabled. I was able to reproduce the problem. I ran
> configure as './configure --enable-ipv6 --enable-prelude' and ran
> 'make'. Here is the relevant error:
>
> ... snip ...
>
> gcc -DHAVE_CONFIG_H -I. -I../.. -I../.. -I../../src -I../../src/sfutil
> -I/usr/include/pcap -I../../src/output-plugins
> -I../../src/detection-plugins -I../../src/dynamic-plugins
> -I../../src/preprocessors -I../../src/preprocessors/flow
> -I../../src/preprocessors/portscan
> -I../../src/preprocessors/flow/int-snort
> -I../../src/preprocessors/HttpInspect/include
> -I../../src/preprocessors/Stream5 -I../../src/target-based
> -fno-strict-aliasing -g -O2 -Wall -pthread -DSUP_IP6 -DDYNAMIC_PLUGIN
> -fno-strict-aliasing -c spo_alert_prelude.c
> spo_alert_prelude.c: In function 'packet_to_data':
> spo_alert_prelude.c:415: error: incompatible type for argument 1 of
> 'sfip_to_str'
> spo_alert_prelude.c: In function 'AlertPreludeSetup':
> spo_alert_prelude.c:801: warning: passing argument 3 of
> 'RegisterOutputPlugin' from incompatible pointer type
> make[3]: *** [spo_alert_prelude.o] Error 1
> make[3]: Leaving directory `/usr/src/snort-2.8.1/src/output-plugins'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/usr/src/snort-2.8.1/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/snort-2.8.1'
> make: *** [all] Error 2
>
> Thank You,
> Christopher Blume
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by the 2008 JavaOne(SM) Conference
> Don't miss this year's exciting event. There's still time to save $100.
> Use priority code J8TL2D2.
> http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone
> _______________________________________________
> Snort-devel mailing list
> Snort-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/snort-devel
>



This SF.net email is sponsored by the 2008 JavaOne(SM) Conference Don't miss this year's exciting event. There's still time to save $100. Use priority code J8TL2D2.
http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone

Snort-devel mailing list
Snort-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/snort-devel