samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] unable to join to a Samba4 domain

Re: [Samba] unable to join to a Samba4 domain

From: Tomasz Chmielewski <mangoo_at_nospam>
Date: Mon May 31 2010 - 09:58:50 GMT
To: Lukasz Zalewski <lukas@dcs.qmul.ac.uk>

Am 29.05.2010 20:58, Lukasz Zalewski wrote:
> On 29/05/2010 19:17, Tomasz Chmielewski wrote:
>> Am 29.05.2010 20:15, Lukasz Zalewski wrote:
>>
>>>> Unfortunately, Windows XP SP3 fails to join a Samba4 domain as well.
>>>>
>>>> How can I troubleshoot it?
>>
>>> Are both the samba4 and client machine on the same subnet? If not are
>>> there any firewalls, or routers in the way?
>>
>> Same subnet, no firewalls or routers on the way.
>
>>
>>> Is your client dns configuration pointing explicitly at samba4
>>
>> Yes.
>>
>>
>
> Hmm this is mostly odd,
> are you using FQDN to join the domain?

Yes.

> Can you resolve all of the samba4 generated dns records externally
> (http://wiki.samba.org/index.php/Samba4/HOWTO Configure DNS section),
> such as
> host -t SRV _ldap._tcp.samdom.example.com.

Yes, it works correctly (as is /usr/local/samba/sbin/samba_dnsupdate
--verbose).

You'll find an attached pcap file produced by Wireshark made on the
Windows XP machine.
It shows DNS and LDAP queries flow both ways.

Do you see anything unusual there?

-- Tomasz Chmielewski http://wpkg.org

-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba