samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] upgrade 3.0.28 to 3.5.3 (SerNet package

Re: [Samba] upgrade 3.0.28 to 3.5.3 (SerNet package)

From: John H Terpstra <jht_at_nospam>
Date: Wed May 26 2010 - 23:18:16 GMT
To: samba@lists.samba.org

On 05/26/2010 05:01 PM, Johan Landerholm wrote:
> Hi all,
>
> I have been upgrading the samba package on a SLES10 (i686) machine with
> the new SerNet 3.5.3 package.
> The server is using the ldap backend for users and passwords.
> It has been working fine until I tried to use a DOS lan manager client.
> A normal user was not able to "net use * \\server\share" and
> authenticate using the userid and password.
> The error message in the smbd.log file was NT_WRONG_PASSWORD.
> I have made no changes to the smb.conf file between the two binary
> versions.
> If I switch back from 3.5.3 to 3.0.28, the user is able to log map the
> drive.
>
> Is there something that has changed between the two that disables the
> possibility to use a DOS client with samba ?

Yes, LanMan passwords are not supported in later versions. This was
done for security reasons. You can re-enable them by adding to smb.conf
[globals]
        lanman auth = yes

- John T.

> The relevant pieces from smb.conf:
>
> passdb backend = ldapsam:ldap://127.0.0.1
> security = user
> encrypt passwords = Yes
> domain logons = yes
> os level = 35
> acl compatibility = Auto
> client lanman auth = no
> null passwords = true
>
> Thanks for any help!
>
> /Johan

-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba