samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] unable to join to a Samba4 domain

Re: [Samba] unable to join to a Samba4 domain

From: Lukasz Zalewski <lukas_at_nospam>
Date: Tue May 25 2010 - 18:55:55 GMT
To: Tomasz Chmielewski <mangoo@wpkg.org>

On 25/05/2010 14:08, Tomasz Chmielewski wrote:
> Am 25.05.2010 14:50, Tomasz Chmielewski wrote:
>> Am 25.05.2010 13:58, Lukasz Zalewski wrote:
>>
>>>> What more info should I provide?
>>>>
>>>>
>>>
>>> The only way i can replicate your problem and get simmilar message, is
>>> by blocking access to port 389 both TCP and UDP on the samba4 host - it
>>> seems like enabling either (i.e. TCP or UDP) produces enter credentials
>>> dialog. Note that i have used Windows 7 rather than Srv2008
>>
>> The only packets exchanged, from the moment I press "OK" button to
>> when the error is shown, are:
>>
>> - DNS queries
>> - LDAP queries
>>
>> (192.168.128.11 - Samba4; 192.168.128.12 - Windows 2008)
>>
>> So, nothing blocked on Samba4 side (and LDAP queries add some data to
>> Samba debug log).
>
> If I block LDAP on UDP, Windows does not send queries to LDAP on TCP. Is
> it the same for you?
>
> And indeed, the error message is the same whether 389/UDP is blocked or
> not.
>

I'n my case if one protocol (TCP or UDP) in that port is enabled things
seem to work. if both are disabled i get the error message. Have you
tried to disable firewall on samba4 host just to rule it out? Presumably
you don't have any other firewalls in the way? I will try to join
Windows 2008 to the domain tomorrow as a test.
Luk
-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba