samba-users August 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] Domain not available even minutes after

Re: [Samba] Domain not available even minutes after workstation startup

From: Gaiseric Vandal <gaiseric.vandal_at_nospam>
Date: Wed Sep 01 2010 - 02:50:37 GMT
To: "'Abe Lau'" <abelau+samba@gmail.com>

Did you try disabling the media sensing feature? I need to look at some of my Active Directory XP clients and see if they are still getting the error.

 

I don’t think it prevented people logging on, and I am not using roaming profiles, so even if I still have this issue on occasion it might not be obvious. I think I had run into it when trying to deploy software through group policies. This was a few years ago but I think I had got it resolved.

 

You could try putting one of the problem XP machines on a 10 Mbit only link. Or maybe see if you can configure the NIC settings be be 10 Mbit OR 100 Mbit but not autosensing.

 

From: abelau@gmail.com [mailto:abelau@gmail.com] On Behalf Of Abe Lau
Sent: Tuesday, August 31, 2010 8:22 PM
To: gaiseric.vandal@gmail.com
Cc: samba@lists.samba.org
Subject: Re: [Samba] Domain not available even minutes after workstation startup

 

Thanks Gaiseric for the note.

I checked the XP Event Log, and the only error is:

Automatic certificate enrollment for local system failed to contact the active directory (0x8007054b). The specified domain either does not exist or could not be contacted. Enrollment will not be performed.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

The only suspicious entry in samba log: (I remember this could safely be ignored)

[2010/09/01 09:10:17, 1] smbd/session.c:111(session_claim) Re-using invalid record

The PDC was changed to connect via two bonded gigabit connection (balance-alb) in a mixed 1000/100 network few months ago. Contrary to the MS support link, we have problem with both 100Mbps and 1000Mbps connections intermittently.

Is any way to get XP to split out detailed log when it says "domain is not available"?

Is setting Winlogoncachedlogonscount the good way to avoid logon problem when network is not ready during initial bootup? According to MS, if the domain server is not available and logon data is not cached, "domain is not available" will occur.

http://technet.microsoft.com/en-us/library/cc957390.aspx

Any further insight?

Abe

On Tue, Aug 31, 2010 at 10:00 PM, Gaiseric Vandal <gaiseric.vandal@gmail.com> wrote:

Did you check the event logs in Windows- they may provide some additional info.

This error sounded familiar- most of my users are in a Samba domain, but I have one group that uses Windows 2003 active directory domain. A few years back they had some weird issues that ended up being (possibly) related to the gigabit network connection. It had been hard to trace and had only been affecting newer machines.

I think the following link was relevant.

http://support.microsoft.com/kb/326152/

On 08/30/2010 11:29 PM, Abe Lau wrote:

Yes, the PDC is also acting as the WINS server. The XP workstation is using WINS, set via DHCP (option netbios-name-servers <ip address of the PDC>;)

On Mon, Aug 30, 2010 at 10:43 PM, Gaiseric Vandal <gaiseric.vandal@gmail.com <mailto:gaiseric.vandal@gmail.com>> wrote:

   Is the PDC also a WINS server? Are the XP workstations using WINS?

   On 08/29/2010 09:01 PM, Abe Lau wrote:

       Hi all,
       I have recently experienced an intermittent problem of getting
       the error
       message of "Domain not available" at initial logon of some XP
       workstations
       connected to a Samba PDC. The domain does not seems to be
       available after
       some time after initial bootup of the XP workstation, from a
       minute or two,
       to more than 10 minutes sometimes.

       Is there anyway to speed up this process? Thanks!

       I have set HKLM\SOFTWARE\Microsoft\Windows
       NT\CurrentVersion\Winlogoncachedlogonscount to 0 to workaround
       the problem
       of having the logon frozen (and folders not being redirected)
       during initial
       logon when the network is not ready.

       Abe

   -- To unsubscribe from this list go to the following URL and read the
   instructions: https://lists.samba.org/mailman/options/samba

-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba -- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba