samba-users August 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: [Samba] Problems Joining AD/Domain

[Samba] Problems Joining AD/Domain

From: Nicholas Betcher <nbetcher_at_nospam>
Date: Tue Aug 24 2010 - 01:51:51 GMT
To: samba@lists.samba.org

Hello,
I am working at a company where officially my job duty is unrelated to
my problem. However, I am coordinating with my company's chief IT
admin to create a Linux workstation for our call center to extend the
life of our outdated computers. However, I am stuck at trying to get
the workstation to join the domain. When I attempt to join the domain
using YaST (openSUSE's system configuration tool) it prompts me for a
network admin's username/password (same as 'net join DOMAIN'). While I
understand the need for having this access, unfortunately it is out of
the question due to several reasons (mainly that I work on this at
night/overnight when he's gone, plus he doesn't know what Samba would
"do" to the network).

Although joining a workstation to a domain requires administrative
privileges, he told me that he joined my workstation to the domain
(using MAC/IP or some combo, I'm not sure). However when I do a 'net
join DOMAIN' it still prompts for a username/password. I know that he
added the workstation because at one point I managed to trick Samba,
but it said the machine's network password was empty. So, the question
being: how do I join this PC to the domain with NO admin user/pass
assuming that he did in fact add the PC to the domain on the AD
server's side?

Thanks!
Nick Betcher
-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba