samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: [Samba] strange error in log.nmbd - packets.c

[Samba] strange error in log.nmbd - packets.c

From: Chris Smith <smb_77_at_nospam>
Date: Sat May 08 2010 - 23:49:01 GMT
To: Samba List <samba@lists.samba.org>

Running samba-3.5.2 I notice this in the log.nmbd file after starting samba:
===============================================================
[2010/05/08 19:10:44.652249, 0] nmbd/nmbd_packets.c:738(queue_query_name)
  queue_query_name: interface 1 has NULL IP address !
[2010/05/08 19:10:44.652298, 0] nmbd/nmbd_packets.c:738(queue_query_name)
  queue_query_name: interface 1 has NULL IP address !
===============================================================

I discovered that this occurs with:
bind interfaces only = Yes
and one of the following:
===========================
interfaces = 192.168.107.6 lo
or
interfaces = eth0 lo
===========================

no other combinations cause the issue:
===========================
interfaces = 192.168.107.6 127.0.0.1
or
interfaces = lo 192.168.107.6
or
interfaces = lo eth0
or
interfaces = 127.0.0.1 192.168.107.6
or
interfaces = 127.0.0.1 eth0
===========================

Basically only when "lo" is specified second by name is the problem
seen, "lo"'s IP address works in all cases either first or second.

For now I've switched to using:
===========================
interfaces = lo 192.168.107.6
===========================
as I have 2 addresses on eth0 and only want samba to bind to one of them.

Chris
-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba