samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] smb.conf works for 3.4.0; doesn't work

Re: [Samba] smb.conf works for 3.4.0; doesn't work for 3.4.7

From: Mike Leone <turgon_at_nospam>
Date: Sat May 08 2010 - 13:42:46 GMT
To: Christian PERRIER <bubulle@debian.org>

On 05/08/2010 04:00 AM, Christian PERRIER wrote:

> Quoting Mike Leone (turgon@mike-leone.com):
>
>
>> directories. Even tho Ubuntu 10.04 seems to have the /etc/pam.d files
>> already configured for samba, I copied over the common-account,
>> common-auth, common-password, common-session files from the 9.10 server
>> to the 10.04 server. Did the same with the nsswitch.conf file.
>>
> This is very very probably the source of all your problems.
>

No, I get the exact same results, using the original files as provided
by Ubuntu. I thought *they* were the cause of the problem, so that's why
I changed them to match the working ones on the other server.

> the chances that
> your manual changes broke the planned upgrade path are high.
>
 I kep copies of the original files, and replaced my changes with those.
Exact same errors - getent passwd fails.

>
> I'm suggest putting the common-* files you had after upgrading and
>

There was no upgrade. This was a clean install of 10.04.

> before replacing them with those of 9.10 (you kept them somewhere,
> right?) in place and reconfigure packages with "dpkg-reconfigure
> winbind".
>
>
Did that. Exact same error - getent passwd fails.

-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba