samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] Permission problems on Mac OS X

Re: [Samba] Permission problems on Mac OS X

From: Andrea Venturoli <ml_at_nospam>
Date: Sat May 08 2010 - 13:01:13 GMT
To: samba@lists.samba.org

On 04/23/10 11:49, Andrea Venturoli wrote:
> On 03/03/10 13:37, Eero Volotinen wrote:
>> 2010/3/3 Andrea Venturoli<ml@netfence.it>:
>>> I know this might be half OT, but nontheless Samba is involved.
>>>
>>> A customer of mine has two Macs with Mac OS X 10.5 and is sharing a
>>> folder
>>> on one of them.
>>> We'd like to avoid any permission problem, so I put the followinf in
>>> smb.conf:
>>>
>>> create mode=0777
>>> force create mode=0777
>>> directory mode=0777
>>> force directory mode=0777
>>>
>>> This is usually enough to achieve what I want, with other OSes.
>>>
>>>
>>> However, when the second Mac (the client) creates a file with
>>> OpenOffice.org, it will have mode 0755.
>>>
>>>
>>> I was told this is a known problem, solvable with:
>>> unix extensions=false.
>>>
>>> I tried this too, but it doesn't seem to make any difference.
>>>
>>> Any hint?
>>
>> please attach output from testparm
>
> Sorry for taking sooooo long (I only had this info now from my customer).
> Here is testparm's output:
>
>> [global]
>> dos charset = 437
>> unix charset = UTF-8-MAC
>> display charset = UTF-8-MAC
>> realm = LKDC:SHA1.FFBD38547C80ABE9EB01FDFBDB1BB7D248814AD9
>> server string = XXXXXXXXXXXXXXXX
>> enable print services = No
>> auth methods = odsam
>> obey pam restrictions = Yes
>> passdb backend = odsam
>> lanman auth = No
>> use kerberos keytab = Yes
>> log level = 1
>> debug pid = Yes
>> max xmit = 131072
>> name resolve order = lmhosts wins bcast host
>> unix extensions = No
>> max smbd processes = 10
>> printcap name = cups
>> os level = 2
>> preferred master = No
>> domain master = No
>> usershare allow guests = Yes
>> usershare allow full config = Yes
>> usershare max shares = 1000
>> usershare owner only = No
>> usershare path = /var/samba/shares
>> idmap domains = default
>> idmap alloc backend = odsam
>> idmap negative cache time = 5
>> com.apple:lkdc realm = LKDC:SHA1.FFBD38547C80ABE9EB01FDFBDB1BB7D248814AD9
>> com.apple:filter shares by access = yes
>> darwin_streams:brlm = yes
>> idmap config default:backend = odsam
>> idmap config default:default = yes
>> acl check permissions = No
>> ea support = Yes
>> stream support = Yes
>> use sendfile = Yes
>> printing = cups
>> print command =
>> lpq command = %p
>> lprm command =
>> include = /var/db/smb.conf
>> vfs objects = darwinacl, darwin_streams
>>
>> [homes]
>> comment = User Home Directories
>> read only = No
>> create mask = 0750
>> browseable = No
>> com.apple:show admin all volumes = yes
>>
>> [printers]
>> comment = All Printers
>> path = /tmp
>> create mask = 0700
>> printable = Yes
>> browseable = No
>>
>> [condivisa]
>> path = /Users/Shared/Condivisa
>> valid users = xxxxxxx, yyyyyy
>> read only = No
>> create mask = 0777
>> force create mode = 0777
>> directory mask = 0777
>> force directory mode = 0777
>> inherit acls = Yes
>
>
> The share I'm experiencing the problem on is the last ("condivisa").
>
> bye & Thanks
> av.

Any hint on this?

  bye & Thanks
        av.
-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba