samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] Samba 3.5.2 packages for Debian lenny

Re: [Samba] Samba 3.5.2 packages for Debian lenny

From: Rippl, Steve <rippls_at_nospam>
Date: Wed May 05 2010 - 21:09:50 GMT

Thanks for doing this!

On Wed, May 5, 2010 at 2:05 PM, Christian PERRIER <>wrote:

> (please note that this mail is crossposted to 3 lists. No need to CC
> me to answers, I read the 3 of them...)
> Some users (including me with my professionnal hat) want to use 3.5
> versions of samba on production servers running Debian. Of course,
> most of the time, these production servers are running Debian lenny
> (the stable version of the distribution).
> Debian lenny ships with samba 3.2.5, so these users need a
> "backported" package....or to compile packages themselves.
> We already had backports of samba 3.4.7, which is the version
> currently shipped in Debian "testing" (aka "the next Debian
> version"). These are available through the
> service, also known as the "nearly completely official backport
> service of the Debian project".
> The policy of does not allow us to provide 3.5 packages
> there, because these versions are not in Debian testing.
> So, as a service to our users, I prepared some packages which are now
> available from, also known as "the
> not so official but still quite actively supported backport service of the
> samba packaging team of the Debian project" (which makes a fairly long
> name...).
> These packages are functionally identical to 3.5.2 package we provide
> in Debian experimental....but are usable on Debian "lenny" systems.
> There are however a few limitations:
> - they're provided only for i386 and amd64 architectures
> - they require the backported cifs-utils, ctdb and libtalloc2 packages
> from (cifs-utils is only required if you previously
> had the "smbfs" package that provide (u)mount.cifs
> To use these packages, you need to add the following to
> /etc/apt/sources.list:
> deb lenny-backports main contrib non-free
> deb lenny-backports-latest/
> Then packages must be installed with:
> apt-get install -t lenny-backports-latest samba <winbind> ....
> Please note that these packages are not (yet) digitally signed, so
> apt-get might complain and ask for confirmation. I should improve this
> in the future. This is why this mail is currently GPG-signed with the
> key I'm using for Debian packaging.
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:

-- Steve Rippl Technology Director Woodland Public Schools 360 225 9451 x326 -- To unsubscribe from this list go to the following URL and read the instructions: