samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] Long Delay on Fresh Windows 7 Clients

Re: [Samba] Long Delay on Fresh Windows 7 Clients

From: David Holder <david.holder_at_nospam>
Date: Tue May 04 2010 - 08:33:06 GMT
To: Kevin Keane <subscription@kkeane.com>

Kevin,

> share by typing its static IP address: \\192.168.0.13\sharename.
With this form of the connection UNC Windows will only ever use IPv4,
IPv6 will not be involved.

Regards,
David
------------------------------------------------------------------------
Dr David Holder CEng FIET MIEEE

Erion Ltd, Oakleigh, Upper Sutherland Road, Halifax, HX3 8NT

Reception: +44 (0)1422 207000

Direct Dial: +44 (0)131 2026317

Cell: +44 (0) 7768 456831

Registered in England and Wales. Registered Number 3521142
VAT Number: GB 698 3633 78

Kevin Keane wrote:
> It may also be network discovery, and/or an IPv6 issue. Windows 7 tries to default to IPv6. There is no NETBIOS or WINS in IPv6, so DNS is pretty much mandatory (there also is Network Discovery, which is basically UPnP renamed).
>
> My guess is that in your case, Windows 7 first tries to resolve 192.168.0.13 to an IPv6 address using DNS. Then it probably tries to look for it with UPnP. Only when those two fail would it use IPv4.
>
> Disabling IPv6 is really a bad idea, but with Samba it may be your only option.
>
>
>> -----Original Message-----
>> From: samba-bounces@lists.samba.org [mailto:samba-
>> bounces@lists.samba.org] On Behalf Of smbatsc@gmx.com
>> Sent: Monday, May 03, 2010 3:52 PM
>> To: samba@lists.samba.org; michele.petrazzo@unipex.it
>> Subject: Re: [Samba] Long Delay on Fresh Windows 7 Clients
>>
>> Thank you very much Michele. Because it's not trivial for me to
>> introduce DNS for the local Samba server, I just tried accessing the
>> share by typing its static IP address: \\192.168.0.13\sharename.
>>
>> I still get the same delay.
>>
>> Perhaps it's not DNS resolution that's causing that?
>>
>> Thanks,
>> Daniel
>>
>> mich...@unipex.it wrote:
>> smba...@gmx.com wrote:
>>
>>> When I type \\sambahost\sharename, a prompt for the username and
>>> password will eventually appear (and let me authenticate
>>> successfully) but it takes almost forever (i.e. 1-5 minutes) until
>>> that prompt dialog box appears.
>>>
>>>
>> Last week week my customer call me for the same problem where I
>> installed an "old" version of samba (like yours) without local dns.
>> After some tests, a simple bind9 + master local zone and reversed one
>> solved the problem.
>> I don't know further technical details, but I presume that 7 _need_ a
>> reply from a dns. If it not find a good one, before gone to timeout and
>> switch to wins resolution, it took *a lot of time*
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions: https://lists.samba.org/mailman/options/samba
>>
-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba