samba-users May 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] win 7, samba 3.4.7, error 0x000003e6 wi

Re: [Samba] win 7, samba 3.4.7, error 0x000003e6 with some printers

From: Luca Olivetti <luca_at_nospam>
Date: Mon May 03 2010 - 14:17:28 GMT
To: samba@lists.samba.org

En/na Luca Olivetti ha escrit:
> Hello,
>
> I'm testing windows 7 with samba 3.4.7 and I'm using PrintUIEntry to
> connect the printers.
> With some of those printers the connection fails (client side) with
> error 0x000003e6.
> The strange thing is that:
>
> 1) trying the same connection against samba 3.0.11 works (alas, no
> domain functionality with that old version) and
>
> 2) two of the failing printers share the same driver with one that works
>
> Looking at the level 10 log I see some WERR_INSUFFICIENT_BUFFER errors,
> but those are present also in the log for the printer that can connect
> successfully.
> Diffing the log between a functioning printer and a failing one, the
> only difference (apart from the names) is that the failing printer has
> the PRINTER_ATTRIBUTE_PUBLISHED set.
>
> Needless to say, windows xp has no problem with either samba 3.0.11 or
> samba 3.4.7.
>
> Any hint?

Never mind, deleting the conflicting printers from win 7 and reassigning
the already available driver (with the ensuing dance of printer
renaming) seems to have fixed it.

Bye
-- Luca Olivetti Wetron Automatización S.A. http://www.wetron.es/ Tel. +34 93 5883004 (Ext.133) Fax +34 93 5883007 -- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba