samba-users August 2010 archive
Main Archive Page > Month Archives  > samba-users archives
samba-users: Re: [Samba] Throughput problem with Samba 3.3.4 ove

Re: [Samba] Throughput problem with Samba 3.3.4 over VPN

From: Volker Lendecke <Volker.Lendecke_at_nospam>
Date: Thu Aug 05 2010 - 14:29:14 GMT
To: Ludovic Rouse-Lamarre <ludovic.rouse-lamarre@xyzcivitas.com>

On Thu, Aug 05, 2010 at 10:06:40AM -0400, Ludovic Rouse-Lamarre wrote:
> I am currently in the process of improving performance for a Samba 3.3.4
> server on FreeBSD 7.0. The samba server works great when mounted from
> another machine located on the same network but when I try to use it
> over our corporate VPN (OpenVPN with tap interface) the throughput won't
> go over 4,5 Mbps. The ping between the samba client and the server is
> around 20ms. I have used a linux machine on amazon's elastic cloud to
> connect to the corporate VPN and mount the samba share located on our
> web host. There is at least 20 Mbps of bandwidth available between the
> two in both ways.
>
> I have also tested the throughput from our Montreal office where we have
> a 10 Mbps download. I have tested with fedora, windows 7 and windows xp
> and I can't get more than 4 or 5 Mbps there.
>
> Is this situation to be expected or should I be getting better throughput?

Try the smbclient get command. That should be better.
If it is, everything else is pretty much a client problem.

Volker
-- To unsubscribe from this list go to the following URL and read the instructions: https://lists.samba.org/mailman/options/samba