postfix-users May 2014 archive
Main Archive Page > Month Archives  > postfix-users archives
postfix-users: Re: Berkeley DB6 and Postfix

Re: Berkeley DB6 and Postfix

From: Sahil Tandon <sahil+postfix_at_nospam>
Date: Sun May 11 2014 - 23:20:32 GMT
To: postfix-users@postfix.org

On Sun, 2014-05-11 at 18:18:45 -0400, Jerry wrote:

> The installation halts immediately with this error message:
>
> ===> postfix-current-2.12.20140507,4 cannot install: does not work with Berkeley DB version 6 (6 not supported).

That is deliberately triggered when someone tries to build the Postfix
port WITH_BDB_VER=6. This is so that users do not begin building, only
to encounter:

  dict_db.c:705:2: error: "Unsupported Berkeley DB version"

> Is this correct or am I doing something terribly wrong? Version "6"
> has been out for quite some time now and I would have thought that
> Postfix would have supported it.

Based on src/util/dict_db.c, the latest supported Berkeley DB major
version is 5.

-- Sahil Tandon