metasploit-framework May 2011 archive
Main Archive Page > Month Archives  > metasploit-framework archives
metasploit-framework: [framework] no active driver available

[framework] no active driver available

From: Giorgio Casali <giorgio.casali_at_nospam>
Date: Sat May 14 2011 - 23:25:07 GMT
To: framework@spool.metasploit.com

Hello everyone, I have a fresh BT5 install and just svn updated the
metasploit framework, however even after installing the mysql and pg gems I
still receive the:
same error message:

msf > db_driver
[*] No Active Driver
[*] Available:

[*] DB Support: Enable the mysql driver with the following command:
[*] $ gem install mysql
[*] This gem requires mysqlclient headers, which can be installed on
Ubuntu with:
[*] $ sudo apt-get install libmysqlclient-dev

[*] DB Support: Enable the postgresql driver with the following command:
[*] * This requires libpq-dev and a build environment
[*] $ gem install postgres
[*] $ gem install pg # is an alternative that may work

Thanks.
Regards,
G.

_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework