drbd-user March 2010 archive
Main Archive Page > Month Archives  > drbd-user archives
drbd-user: Re: [DRBD-user] drbd just ate my data

Re: [DRBD-user] drbd just ate my data

From: Ben Chobot <bench_at_nospam>
Date: Mon Mar 22 2010 - 23:42:15 GMT
To: Cameron Smith <velvetpixel@gmail.com>

I think the moral of your unfortunate story is to understand what you are doing, and not to randomly poke at things which aren't working the way you want them to.

Why were you trying to create a filesystem on /dev/drbd1 on web001? Presumably that was supposed to be your replicated version from web002?

On Mar 22, 2010, at 4:37 PM, Cameron Smith wrote:

> I have two nodes.
>
> web002
> web001
>
> I initially set up drbd on web002 created the filesystem on /dev/drbd1 with a mount point of /data.
>
> Web002 should be primary for now.
>
> I transferred lots of files and directories to /data on web002.
> it was working.
>
> I then went to install drbd on web001 and ran into a problem.
>
> When I tried to install a filesystem on /dev/drbd1 on web001 I got an error from drbd saying it couldn't do that as it was secondary. I figured I could shut down web002, make webb001 primary and then install the filesystem and then make web001 secondary and bring back up web002.
>
> This is when all hell broke loose.
>
>
> I couldn't get the filesystem to install on web001 so I figured I would bring back up web002 and when I did the filesystem mounted at /data does not come up.
>
> Web002 came back as secondary and the two systems started syncing without me noticing and now all my 186GB of data from web002 is gone.
>
> Awesome :(
>
> What is the correct procedure to prevent this and the right way to bring in a new node?
>
> Thanks,
> Cameron
> _______________________________________________
> drbd-user mailing list
> drbd-user@lists.linbit.com
> http://lists.linbit.com/mailman/listinfo/drbd-user

_______________________________________________
drbd-user mailing list
drbd-user@lists.linbit.com
http://lists.linbit.com/mailman/listinfo/drbd-user