drbd-user May 2010 archive
Main Archive Page > Month Archives  > drbd-user archives
drbd-user: Re: [DRBD-user] [Xen-users] interesting installation

Re: [DRBD-user] [Xen-users] interesting installation problem - interaction between drbd and xen

From: Fajar A. Nugraha <fajar_at_nospam>
Date: Mon May 17 2010 - 03:27:34 GMT
To: Miles Fidelman <mfidelman@meetinghouse.net>

On Sat, May 15, 2010 at 7:51 AM, Miles Fidelman
<mfidelman@meetinghouse.net> wrote:
> Configuration this applies to:
> Debian Lenny

> xendomains was trying to bring up VMs, before drbd devices were initialized
> - leading to all kinds of weirdness. The domains would try to come up, get
> through the boot stages, and then hang as soon as they tried to mount root
> and swap.

That, by itself, is strange. Whether you use phy:/dev/drbd*, or
block-drbd scripts, the drbd resource should not be accessible if drbd
has not been started yet. Not accessible means the domU should not be
able to start at all.

>
> Changing S21xendomains to S76xendomains (after both drbd and hearbeat)
> solved the problem.
>
> WHICH LEADS TO A QUESTION:
>
> This isn't really a bug with any one piece of code - it's a bug in the
> interaction, specifically in the naming/ordering of the init package. And I
> expect that this may be specific to packaging (I'm going to do more
> digging). SO WHERE DO I FILE A BUG REPORT?

Since you use debian packages, your best bet is to contact their
package maintainer, or use their bug report mechanism.
http://packages.debian.org/lenny/xen-linux-system-2.6.26-2-xen-686
-- Fajar _______________________________________________ drbd-user mailing list drbd-user@lists.linbit.com http://lists.linbit.com/mailman/listinfo/drbd-user