drbd-user March 2010 archive
Main Archive Page > Month Archives  > drbd-user archives
drbd-user: Re: [DRBD-user] Debian init problem

Re: [DRBD-user] Debian init problem

From: Lars Ellenberg <lars.ellenberg_at_nospam>
Date: Fri Mar 12 2010 - 11:19:44 GMT
To: drbd-user@lists.linbit.com

On Fri, Mar 12, 2010 at 11:17:38AM +0100, Massimo CtRiX Cetra wrote:
> Lars Ellenberg ha scritto:
> >>block drbd0 : bind before connect failed error = -99
> >>
> >>I have to make a /etc/init.d/drbd restart, and all work fine ... I
> >>don't know where the error is ... Any ideas ?
> >
> >You have to get your network up,
> >before you tell drbd to use it.
> have had this problem myself some times ago and you gave me the same answer.
> I solved whe problem with a sleep 1 at the beginning od drbd init
> script which, as you know, are executed sequentially.
> This implies that the network was up.
>
> When using DRBD virtual machines, everything is so fast that DRBD
> fails to bind.

You (your init script/lines and hacks you add to your init scripts)
have to make sure that the _address_ is available before you tell
drbd to use that address.

If the address is not available, "network start"
(or whatever it is called) should not have returned yet,
and if it does, I'd argue it is broken.
Could this be "upstart" related?

Imaginge an Apache directive Listen 10.11.12.13:80
which will also fail if no 10.11.12.13 is available at that point.

-- : Lars Ellenberg : LINBIT | Your Way to High Availability : DRBD/HA support and consulting http://www.linbit.com DRBD® and LINBIT® are registered trademarks of LINBIT, Austria. __ please don't Cc me, but send to list -- I'm subscribed _______________________________________________ drbd-user mailing list drbd-user@lists.linbit.com http://lists.linbit.com/mailman/listinfo/drbd-user