drbd-user March 2010 archive
Main Archive Page > Month Archives  > drbd-user archives
drbd-user: Re: [DRBD-user] problem with building drbd latest ver

Re: [DRBD-user] problem with building drbd latest version (latest git checkout)

From: Lars Ellenberg <lars.ellenberg_at_nospam>
Date: Thu Mar 11 2010 - 14:49:12 GMT
To: drbd-user@lists.linbit.com

On Thu, Mar 11, 2010 at 03:15:34PM +0100, Peter den Hartog wrote:
> Hello,
>
> I'm trying to build DRBD on a Debian 5 system. But it fails, here you can
> find the terminal output; http://pastebin.com/4t2GEyBq
>
> Here you can find the how-to i used: http://www.drbd.org/docs/install/
> I just did a GIT checkout. Everything goes fine untill i have to build the
> kernel module, that gives the above output.
>
> Any pointers how to fix this?

Don't build against git, wait for git to be updated to contain the build
fix (I have it already), use a kernel version that drbd git will
currently build against, build against a tagged release from git, build
against a release tarball, or use packages build for you.

Quoting http://www.drbd.org/download/development-code/

    You can browse the latest state of development
    in our Git Repository git.drbd.org.
    Note that sometimes this code might not even compile,
    but we try to avoid that.

Sometimes we do a fix against the latest greatest,
but break some older kernels along the way.

-- : Lars Ellenberg : LINBIT | Your Way to High Availability : DRBD/HA support and consulting http://www.linbit.com DRBD® and LINBIT® are registered trademarks of LINBIT, Austria. __ please don't Cc me, but send to list -- I'm subscribed _______________________________________________ drbd-user mailing list drbd-user@lists.linbit.com http://lists.linbit.com/mailman/listinfo/drbd-user