drbd-user March 2010 archive
Main Archive Page > Month Archives  > drbd-user archives
drbd-user: Re: [DRBD-user] Primary/Unknown and Secondary/Unknown

Re: [DRBD-user] Primary/Unknown and Secondary/Unknown

From: Maros Timko <timkom_at_nospam>
Date: Sat Mar 06 2010 - 16:57:28 GMT
To: drbd-user@lists.linbit.com

This is very interesting to me. You were happily creating Split-Brains
with the old system. Now there is something that prevents you against
it and you want to "fix" that?
Do you really want to failover on disconnected replication link? What
is the logic behind?
If you really need it, try to check for fencing options and messages.

Tino

> I have faced same problem.
> issue resolved via upgrading kernel from 2.6.16.60-0.54.5(comes with sle10sp3 media) to 2.6.16.60-0.59.1
>
> --ms
>
> ----- Original Message -----
> From: Reindy [mailto:reindy@gmail.com]
> To: drbd-user@lists.linbit.com
> Sent: Fri, 5 Mar 2010 23:33:24 +0800
> Subject: [DRBD-user] Primary/Unknown and Secondary/Unknown
>
> Hi,
>
> I got problem with my drbd+heartbeat.. previously it used to work but
> somehow now.. the situation is..
> I have 2 servers which is currently running primary/secondary and
> secondary/primary
>
> But, when I plug out the crossover cable, somehow the state become
> pri/unknown and sec/unknown..
>
> last time it used to work as pri/unknown and pri/unknown.. this is to make
> sure that the failover is working fine.. now it is not!
>
> Any solution to this guys? really need help on this! Thanks in advance!
>
_______________________________________________
drbd-user mailing list
drbd-user@lists.linbit.com
http://lists.linbit.com/mailman/listinfo/drbd-user