drbd-user March 2010 archive
Main Archive Page > Month Archives  > drbd-user archives
drbd-user: Re: [DRBD-user] 8.3.8 Release to fix external module

Re: [DRBD-user] 8.3.8 Release to fix external module compile against 2.6.33

From: Mike Peachey <mike.peachey_at_nospam>
Date: Fri Mar 05 2010 - 09:33:17 GMT
To: drbd-user@lists.linbit.com

Lars Ellenberg wrote:
> On Thu, Mar 04, 2010 at 12:38:13PM +0000, Mike Peachey wrote:
>> Correct me if I'm wrong, but it seems that 8.3.7 does not compile
>> externally against kernel 2.6.33.
>
> It does not need to,
> as it is included ;-)

For those who have it selected in their kernel..

>
> If you use 8.3.7, don't configure with km, and be happy,
> as that is already included in the 2.6.33 kernel.
>
> If you are using a git checkout, you are ok, too, as you noted above.
>
> So where is the problem?

The problems are providing build scripts for less knowledgeable users
that stick to official releases rather than development trees, where
those users don't have a DRBD-enabled kernel.

>
>> then I am going to have to split the script into userland and module
>
> You should do so anyways.

I will if necessary, but it's not entirely that simple as I am preparing
scripts for a release that doesn't exist yet that need to be backward
compatible and it requires a fair bit more work.

Bottom line is, if absolutely necessary, I will work around it; but
since the fix is already done, if a release is due soon, there's no
point me wasting effort working around a problem that's about to go away
- if that makes sense.
-- Kind Regards, __________________________________________________ Mike Peachey, IT Tel: +44 114 281 2655 Fax: +44 114 281 2951 Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK Comp Reg No: 3191371 - Registered In England http://www.jennic.com __________________________________________________ _______________________________________________ drbd-user mailing list drbd-user@lists.linbit.com http://lists.linbit.com/mailman/listinfo/drbd-user