drbd-user March 2010 archive
Main Archive Page > Month Archives  > drbd-user archives
drbd-user: Re: [DRBD-user] 8.3.8 Release to fix external module

Re: [DRBD-user] 8.3.8 Release to fix external module compile against 2.6.33

From: Lars Ellenberg <lars.ellenberg_at_nospam>
Date: Thu Mar 04 2010 - 18:06:45 GMT
To: drbd-user@lists.linbit.com

On Thu, Mar 04, 2010 at 12:38:13PM +0000, Mike Peachey wrote:
> Correct me if I'm wrong, but it seems that 8.3.7 does not compile
> externally against kernel 2.6.33.

It does not need to,
as it is included ;-)

> It seems this was fixed a week ago in
> Git. I am wondering what the roadmap and timescale is in relation to
> shipping 8.3.8?
>
> I currently provide the SlackBuild to allow installation of DRBD on
> Slackware Linux.
>
> The build works fine on Slackware 13.0 because it uses kernel 2.6.32.7,
> but Slackware-current (which is soon to become Slackware 13.1) can't run
> the build script because it has moved to kernel 2.6.33.

If you use 8.3.7, don't configure with km, and be happy,
as that is already included in the 2.6.33 kernel.

If you are using a git checkout, you are ok, too, as you noted above.

So where is the problem?

> then I am going to have to split the script into userland and module

You should do so anyways.

-- : Lars Ellenberg : LINBIT | Your Way to High Availability : DRBD/HA support and consulting http://www.linbit.com DRBD® and LINBIT® are registered trademarks of LINBIT, Austria. __ please don't Cc me, but send to list -- I'm subscribed _______________________________________________ drbd-user mailing list drbd-user@lists.linbit.com http://lists.linbit.com/mailman/listinfo/drbd-user