drbd-user March 2010 archive
Main Archive Page > Month Archives  > drbd-user archives
drbd-user: [DRBD-user] 8.3.8 Release to fix external module comp

[DRBD-user] 8.3.8 Release to fix external module compile against 2.6.33

From: Mike Peachey <mike.peachey_at_nospam>
Date: Thu Mar 04 2010 - 12:38:13 GMT
To: drbd-user@lists.linbit.com

Correct me if I'm wrong, but it seems that 8.3.7 does not compile
externally against kernel 2.6.33. It seems this was fixed a week ago in
Git. I am wondering what the roadmap and timescale is in relation to
shipping 8.3.8?

I currently provide the SlackBuild to allow installation of DRBD on
Slackware Linux.

The build works fine on Slackware 13.0 because it uses kernel 2.6.32.7,
but Slackware-current (which is soon to become Slackware 13.1) can't run
the build script because it has moved to kernel 2.6.33.

If 8.3.8 is not due out any time soon, then I am going to have to split
the script into userland and module so that 13.1 users will be able to
at least get the tools.

So, what do you think? v8.3.8 due soon maybe?
-- Kind Regards, __________________________________________________ Mike Peachey, IT Tel: +44 114 281 2655 Fax: +44 114 281 2951 Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK Comp Reg No: 3191371 - Registered In England http://www.jennic.com __________________________________________________ _______________________________________________ drbd-user mailing list drbd-user@lists.linbit.com http://lists.linbit.com/mailman/listinfo/drbd-user