clamav-users August 2009 archive
Main Archive Page > Month Archives  > clamav-users archives
clamav-users: Re: [Clamav-users] ClamAV-clamd av-scanner FAILED

Re: [Clamav-users] ClamAV-clamd av-scanner FAILED and ClamAV-clamscanav-scanner FAILED

From: Rodrigo Ruiz Fuentes <rruizf_at_nospam>
Date: Tue Aug 18 2009 - 20:31:48 GMT
To: clamav-users <clamav-users@lists.clamav.net>


On 2009-08-17 15:15, Federico Giovannini wrote:
> Hi all,
>
> I'm new in this mailing-list and also as clamav-user so sorry for my
elementary questions.
> With my configuration gentoo, postfix ( 2.2.11-r1), amavisd-new
(2.5.2) and ClamAV 0.95.2 sometimes when my mailserver receives emails with attachments, clamd stops working and also clamscan dies as indicated in the following amavis logs:
>
> Aug 17 03:42:59 scilla.sestante.net /usr/sbin/amavisd[10531]:
(10531-12) (!!)TROUBLE in check_mail: virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-scanner FAILED: CODE(0x8011a434) Too many retries to talk to /var/amavis/clamd.sock (Can't connect to UNIX socket /var/amavis/clamd.sock: Connection refused) at (eval 67) line 310. at (eval 67) line 511.; ClamAV-clamscan av-scanner FAILED: /usr/bin/clamscan DIED on signal 11 (000b) at (eval 67) line 511.
>
> I took a look also to clamd.log but there are not FATAL evidence.
>
> After this trouble, the crashing emails remain in my postqueue and i
cannot restart clamd until I delete them.
>
> How can I find where is the problem and how can I solve it?
>
> Please Help Me
>
> F.
>
>

Hi everybody,
I have the same problem with clamav with Postfix. Some settings and version software are:

postfix version 2.5.7
amavisd-new version 2.6.1-r1
|
|mail ~ # |uname -mrsp|
Linux 2.6.29-gentoo-r5 x86_64 Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz

mail ~ # clamconf -n
Checking configuration files in /etc

Config file: clamd.conf



LogFile = "/var/log/clamav/clamd.log"
LogTime = "yes"
LogClean = "yes"
LogVerbose = "yes"
PidFile = "/var/run/clamav/clamd.pid"
LocalSocket = "/var/run/clamav/clamd.sock" Debug = "yes"
User = "clamav"
AllowSupplementaryGroups = "yes"

Config file: freshclam.conf



PidFile = "/var/run/clamav/freshclam.pid" AllowSupplementaryGroups = "yes"
UpdateLogFile = "/var/log/clamav/freshclam.log" DatabaseMirror = "database.clamav.net"

clamav-milter.conf not found

Software settings



Version: 0.95.2
Optional features supported: MEMPOOL CLAMUKO AUTOIT_EA06 BZIP2 RAR Database directory: /var/lib/clamav
main.cvd: version 51, sigs: 545035, built on Thu May 14 10:28:45 2009 daily.cld: version 9712, sigs: 64769, built on Tue Aug 18 13:56:37 2009

Thanks in advance for your help.- -- RODRIGO RUIZ FUENTES _______________________________________________ Help us build a comprehensive ClamAV guide: visit http://wiki.clamav.net http://www.clamav.net/support/ml