clamav-users November 2010 archive
Main Archive Page > Month Archives  > clamav-users archives
clamav-users: Re: [Clamav-users] OSX configure command

Re: [Clamav-users] OSX configure command

From: Larry Stone <lstone19_at_nospam>
Date: Sun Nov 14 2010 - 23:41:25 GMT
To: ClamAV users <clamav-users@lists.clamav.net>

On 11/14/10 1:44 PM, Spiro Harvey at spiro@knossos.net.nz wrote:

> This is where your trouble started. This is telling you it can't find
> an appropriate C compiler (gcc).
>
>> configure:3749: found /Developer/usr/bin/gcc
>> configure:3760: result: gcc
>> configure:3989: checking for C compiler version
>> configure:3998: gcc --version >&5
>
> It looks like it found one, but it isn't happy with it.

As I mentioned yesterday, it builds fine for me but my PATH is the default
(or close to it) and does not include all the /Developer directories the OP
has in his. It's just:
/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/local/bin
All programs I've built from source build fine with that.

On my system, both /Developer/usr/bin/gcc and /usr/bin/gcc are softlinks to
gcc-4.2.

> It seems to have plodded along for a bit anyway until it got to..
>
>> ld: library not found for -lcrt1.10.6.o
>
> This is where it looks like it borked. You don't have version 1.10.6
> of the crt lib. But it looks like it's not happy with GCC either.

On my system, I find crt1.10.6.o in /usr/lib but not in /Developer/usr/lib.

This is all with OS X 10.6.5 although I have not built anything since
upgrading from 10.6.4.

-- Larry Stone lstone19@stonejongleux.com http://www.stonejongleux.com/ _______________________________________________ Help us build a comprehensive ClamAV guide: visit http://wiki.clamav.net http://www.clamav.net/support/ml