amavis-user June 2010 archive
Main Archive Page > Month Archives  > amavis-user archives
amavis-user: [AMaViS-user] amavis and spamassassina autolearn

[AMaViS-user] amavis and spamassassina autolearn

From: Stefano Sasso <stesasso_at_nospam>
Date: Sun Jun 13 2010 - 08:42:19 GMT
To: AMaViS-user@lists.sourceforge.net

Hello *,
        using spamassassin from amavisd-new, in the header X-Spam-Status (the
one added by amavis) I always have autolearn=unavailable, but SA works
correctly with autolearn!
In SA logs I found that the autolearn "variable" is correctly set to
ham|spam|no|whatever.
In Example:

Mail header, after amavis processing:
X-Spam-Status: No, score=1.2 required=5 tests=[AWL, BAYES_00,
MISSING_SUBJECT, TO_NO_BRKTS_DIRECT] autolearn=unavailable

SA log: (yes, I'm using amavis with spamc/spamd)
Jun 9 15:28:51 mailfilter-1 spamd[11982]: spamd: result: . 1 -
AWL,BAYES_00,MISSING_SUBJECT,TO_NO_BRKTS_DIRECT
scantime=0.6,size=504,user=(unknown),uid=104,required_score=5.0,rhost=mailfilter-1.domain.it,raddr=127.0.0.1,rport=37098,mid=<20100609132844.78892A5...@mailfilter-1.domain.it>,bayes=0.000004,autolearn=no

It seems that amavis can't read the SA autolearn variable...
any hint?

thanks
Stefano

-- Stefano Sasso http://stefano.dscnet.org/ ------------------------------------------------------------------------------ ThinkGeek and WIRED's GeekDad team up for the Ultimate GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the lucky parental unit. See the prize list and enter to win: http://p.sf.net/sfu/thinkgeek-promo _______________________________________________ AMaViS-user mailing list AMaViS-user@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/amavis-user Please visit http://www.ijs.si/software/amavisd/ regularly For administrativa requests please send email to rainer at openantivirus dot org