amavis-user October 2010 archive
Main Archive Page > Month Archives  > amavis-user archives
amavis-user: [AMaViS-user] Error with Compress::Raw::Zlib: defin

[AMaViS-user] Error with Compress::Raw::Zlib: defines neither package nor VERSION

From: Zhang Huangbin <zhbmaillistonly_at_nospam>
Date: Tue Oct 12 2010 - 02:14:18 GMT
To: amavis-user@lists.sourceforge.net

Hi, all.

I'm running Amavisd-new-2.6.4, and get this error:

(!)Decoding of p002 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 103) line 467

Amavisd RELEASE NOTES mentions:

- require a minimal version 2.017 of Compress::Raw::Zlib when unpacking a
  zip archive (by Archive::Zip) to avoid an archive (e.g. in an infected mail)
  from causing amavisd process to hang; thanks to Alexander 'Leo' Bergolth
  for troubleshooting the memory allocation issue in a zip library;

But I have 2.030 installed:

# rpm -qa perl-Compress-Raw-Zlib
perl-Compress-Raw-Zlib-2.030-1.el5.rf

Any idea?

Another article mentions that it's caused by amavisd v2.6.4:
http://www.claudiokuenzler.com/blog/90
------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1, ECMAScript5, and DOM L2 & L3.
Spend less time writing and rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
AMaViS-user mailing list
AMaViS-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/amavis-user
 Please visit http://www.ijs.si/software/amavisd/ regularly
 For administrativa requests please send email to rainer at openantivirus dot org